-1
$\begingroup$

I've used StackExchange for a couple weeks. I used my Facebook log-in for the site. I took about a week break from it and as of today, when I tried to access Worldbuilding which is my most used network, it asked me to join the community. I click yes, then went through the process thinking its some kind of normal log-in behavior.. only to find my entire worldbuilding account statitsics to be blank!

Oddly enough, as far as I can tell all my other network associations and history remained in tact. I can still find my old Worldbuilding post, which is now attributed to "user93359". Here is an example: Aliens exist on the other side of the nearby wormhole, but we don't know wormhole exists yet. How might they be detected and communicated with?

What can I do about this and how can this be fixed?

$\endgroup$
2
  • 1
    $\begingroup$ And your username "was" Beyond Disbelief, too? If so, that's really weird o_x. $\endgroup$
    – Tortliena
    Jan 18 at 0:26
  • 6
    $\begingroup$ Suspended for voting irregularities, apparently. Ooooo. $\endgroup$ Jan 18 at 5:37

1 Answer 1

3
$\begingroup$

Easy.

You can use the "Contact" button at the bottom of any page on the network, it leads here to a contact-form. You'll be able to leave an explanation/request for a staff member to fix it for you by merging the accounts or re-setting the login for you. It may take a day or two, longer at weekends depending on their workload.

Logging in, personally I use the common stack-exchange login so I can log into all the sites at once, also a password manager, there are many free and secure ones like Lastpass, Stickypassword, Dashlane to save labour. I use Lastpass, it works fine on Android as well as PC.

$\endgroup$

You must log in to answer this question.