I must not be the only person who experiences this. When scrolling down or up there is a noticeable frame-rate drop. What is intended to be smooth ends up been jerky and my processor tries to figure out how to move the high resolution image while keeping the robot on the side in the same place.

I am using a 2017 macOS Catalina with a 2.5GHz i7 processor (no graphics card). I do not experience an issue like this on Math or Physics Stack Exchange.

Although I have tagged this with bug, it really is intended just the be a discussion on what can be done about the frame-rate drop. The background looks pretty, but I do not think it is worth the cost in frame-rate for some users. Is there any work which has already been started to solve this issue?

Edit: A recent answer has identified the issue. It is currently unclear to me how to setup my browser, to automatically disable the fixed scroll feature of the background attachment when I visit Worldbuilding S.E.

  • 1
    $\begingroup$ Does this answer your question? Worldbuilding SE running slowly/choppy scrolling? $\endgroup$
    – minseong
    Commented Mar 6, 2021 at 23:24
  • $\begingroup$ @theonlygusti Please could you explain how to disable the CSS body element while visiting the page? So far as I am aware Safari isn't a html editor. I think your answer will solve the problem, however at the moment it only provides a clear explanation, not a clear fix (to me at least). $\endgroup$
    – user400188
    Commented Mar 7, 2021 at 3:51
  • $\begingroup$ @theonlygusti I have no idea how hard/easy this request is, so please accept my apologies if it is too much to ask. $\endgroup$
    – user400188
    Commented Mar 7, 2021 at 3:59
  • $\begingroup$ You can inspect element in Safari by pressing cmd + alt + i , or by right-clicking and then clicking "inspect element" in the context menu. Then in the Elements tab you have to click the <body class=... element, then scroll through the "Styles" on the right and uncheck the CSS rule. To inspect element, you may have to enable developer settings in Preferences. $\endgroup$
    – minseong
    Commented Mar 7, 2021 at 9:21

1 Answer 1


I think it's because Worldbuilding simply has the most elaborate background. I don't see any in physics.se and the one in math.se is a repetition of a rather small image.

I too browse mostly in laptops, and I don't experience this lag. I have two laptops: a PC with an NVidia graphics card, and a Macbook Air from a few years ago.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .