10
$\begingroup$

So, this mapping site is now mostly working. There's some editing functionality to put in yet, but the vast majority of the work is done. However, as with all new systems, it's likely to be full of bugs. Your mission, should you choose to accept it, is to go and break my site. Find the bugs - any kind, cosmetic, security, random weird stuff because I forgot to handle an edge case, go for it. Please post your bugs in the answers.

In case anyone wants to really try breaking it and going for the database, there's a table set up there called tests. Cookies for you if you can retrieve the contents.

Rewards, you ask? Well, since you mention it, I'm planning to put up some credits. Of course, bug-finders qualify.

Mods (and the community in general really): thanks all for putting up with these posts - they're not quite on topic but it is useful to have them.

$\endgroup$
8
  • 2
    $\begingroup$ I uploaded a map but the access is denied. Sorry, the page you requested (/edit) could not be returned because access to it has been denied. $\endgroup$
    – Vincent
    Jan 4 '15 at 21:49
  • 1
    $\begingroup$ @Vincent /edit isn't up yet, that's a known error :) However, you should have been redirected to /edit/meta?upload=success&filename=Vincent/xxxxxxxxx.xxx if you used the uploader, since I posted this anyway. Old report or were you not redirected properly? $\endgroup$
    – ArtOfCode
    Jan 4 '15 at 22:01
  • $\begingroup$ @HDE226868 Ah right, sorry. Yeah, the header link points to /edit which I haven't actually made yet, and since indexes are disabled you get a 403. The meta-edit screen should be fine. $\endgroup$
    – ArtOfCode
    Jan 4 '15 at 22:26
  • $\begingroup$ @ArtOfCode Ah, got it! All's well. $\endgroup$
    – HDE 226868 Mod
    Jan 4 '15 at 22:28
  • 2
    $\begingroup$ Good good. I'm just waiting for someone to find a security hole and delete the entire website :) $\endgroup$
    – ArtOfCode
    Jan 4 '15 at 22:29
  • 2
    $\begingroup$ Are there any links to maps already uploaded we can look at? Or do we need to login first for that? $\endgroup$
    – Tim B
    Jan 5 '15 at 10:52
  • $\begingroup$ @TimB there are a couple of images up but the display of maps is a little broken so it's just images. The image links shouldn't require login, but they are just pain links to png files. $\endgroup$
    – ArtOfCode
    Jan 5 '15 at 12:16
  • $\begingroup$ This site has been offline for a years now. A meta question about it does now exist: worldbuilding.meta.stackexchange.com/questions/6001/… $\endgroup$
    – Orphevs
    Apr 15 '18 at 11:38
2
$\begingroup$
  1. There is no check for MIME type before allowing an upload. I uploaded a renamed Clipper PRG file as a JPG.

  2. You can't yet view/edit any map. All links for editing go to a 403 error page, access denied.

Will edit as I find more.

$\endgroup$
11
  • $\begingroup$ Thanks! Number 1: Interesting. What kind of password are you using? I've successfully used "aaaa" - I haven't implemented any strength check so this must be something deeper. $\endgroup$
    – ArtOfCode
    Jan 5 '15 at 21:26
  • $\begingroup$ I used sh1mjun as my password. It gave me the error message but still created the account with that password. You probably have an account with the username sample.test.me as well. :) $\endgroup$
    – JohnP
    Jan 5 '15 at 21:28
  • $\begingroup$ I can't look at Number 2 properly until I sort 1. Possibly it returns an error but the account does get created, so the second time you try you can't use the same username. $\endgroup$
    – ArtOfCode
    Jan 5 '15 at 21:28
  • $\begingroup$ Although you did successfully trap a 'select * from tests* in the image title block. $\endgroup$
    – JohnP
    Jan 5 '15 at 21:29
  • $\begingroup$ No account under that username exists in the database... $\endgroup$
    – ArtOfCode
    Jan 5 '15 at 21:30
  • $\begingroup$ Which username? $\endgroup$
    – JohnP
    Jan 5 '15 at 21:30
  • $\begingroup$ sample.test.me. I'll go and try those details, see what I get. $\endgroup$
    – ArtOfCode
    Jan 5 '15 at 21:31
  • $\begingroup$ Has to be said, it works for me $\endgroup$
    – ArtOfCode
    Jan 5 '15 at 21:32
  • $\begingroup$ Hrm. Maybe I misread the error message, as I registered another and got a "Please use a strong password" message. $\endgroup$
    – JohnP
    Jan 5 '15 at 21:34
  • $\begingroup$ Point 5: Your image uploads actually worked fine. This bit is by design - the first image doesn't get overwritten because they are renamed on the server, so a user can have multiple maps of the same image with different map names/ descriptions. $\endgroup$
    – ArtOfCode
    Jan 5 '15 at 21:34
  • $\begingroup$ Let us continue this discussion in chat. $\endgroup$
    – JohnP
    Jan 5 '15 at 21:35

Not the answer you're looking for? Browse other questions tagged .