When I try browsing Worldbuilding (main question list, questions) using Firefox 54.0.1 32-bit on Windows 10, eventually the contents of all Firefox tabs turn completely black. This happens after a "random" but low number of seconds, maybe 2-30. I'm puzzled about this, because:

  • It does not happen in Firefox 54.0 (64-bit) in Ubuntu.
  • It does not happen in Microsoft Edge on the same computer.
  • All tabs turns black, including new tabs that I open, no matter what URL I visit.
  • It only happens with Worldbuilding pages, never any other Stack Exchange sites. Never any other websites.
  • It does not happen on meta.
  • The New Tab Page in Firefox is the only content that seems unaffected.

Restarting Firefox helps, and restores everything. If I restore a previously opened Worldbuilding page, the problem occurs again. If I close the Worldbuilding-tab before restarting, I'm back to normal, everything works.

I don't know how long this has been going on. I normally don't use Windows, but I've been using it occasionally for the last month or so.

The only Firefox extension I use is AdBlock Plus, and disabling it does not help.

So. Something on Worldbuilding does this, but I have no idea how to debug it.

  • 1
    $\begingroup$ How about other Stack Exchange sites? $\endgroup$ – JDługosz Jul 20 '17 at 17:05
  • $\begingroup$ Wow, that sounds irritating. No repro in Firefox 54.0.1 32-bit on Windows 7. $\endgroup$ – Monica Cellio Jul 20 '17 at 18:07
  • $\begingroup$ @JDługosz Nope, they all work as expected. I don't really know what I'm doing here but I've also tried to take a look in the Firefox debug console, but nothing that's obvious to me as an amateur. $\endgroup$ – pipe Jul 20 '17 at 18:38
  • 1
    $\begingroup$ Can you post a screen shot of the black page? $\endgroup$ – adaliabooks Jul 21 '17 at 18:20
  • $\begingroup$ You might look at the thread talking about the WB theme styles, to see who is involved. $\endgroup$ – JDługosz Jul 22 '17 at 12:15
  • 1
    $\begingroup$ You say that disabling AdBlock Plus does not help, but have you tried running Firefox in safe mode and seeing if you can reproduce the issue there? If you can't reproduce it in safe mode, try with a fresh Firefox profile. If you can't reproduce it with either of those, then it's something about your Firefox profile. (Not saying that makes it any less irritating, but it always helps to be able to narrow down the cause.) At least thankfully (a blessing in disguise, I know), it sounds like this is trivially reproducible for you. $\endgroup$ – a CVn Jul 23 '17 at 11:23
  • 2
    $\begingroup$ Most computer glitches go away if you turn off the power, wait a brief moment, reconnect the power, and restart the computer. Many computers are permanently on power, so any weird glitches once they happen persist. This something so unobtrusive and yet so obvious, it's easy to forget. $\endgroup$ – a4android Jul 25 '17 at 2:03
  • 1
    $\begingroup$ Of interest could also be which theme you are using for Firefox. There may be a "disconnect" between the theme you are using, and the CSS for Worldbuilding's theme. You could try using the same theme on Firefox in Ubuntu, and using a different theme for the Firefox in Windows. Also check to see if there's an update for the theme. And, to reiterate what's been asked before can you post a screen shot of the black tabs. $\endgroup$ – user39523 Jul 25 '17 at 3:36

You must log in to answer this question.

Browse other questions tagged .